DataMapper 1.2.0 released

I'm pleased to announce that we have released DataMapper 1.2.0.

This release is focused on bug fixes, performance improvements, internal refactoring and Rails 3.1 compatibility. Please give it a try and in case of any issues please report them on Github.

Installation

DataMapper can be installed with a one-line command:

$ gem install data_mapper dm-sqlite-adapter

The above command assumes you are using SQLite, but if you plan to use MySQL, PostgreSQL or something else replace dm-sqlite-adapter your preferred adapter gem.

IMPORTANT:

If you're not using Rails then remember to call DataMapper.finalize after loading the models!

Changes

dm-core:

dm-adjust:

dm-constraints:

dm-do-adapter:

dm-migrations:

dm-rails:

dm-serializer:

dm-types:

dm-validations:

dm-oracle-adapter: