DataMapper 1.0.0 rc3 released

Today I released DataMapper 1.0.0 rc3. It includes several bugs fixes for issues found in rc2, as well as a few other tickets in the queue.

How do I install rc3?

Since the installation process is pretty similar to rc2, I'm going to give you the abbreviated version. Click here if you would like to see the release notes.

1) Install dm-core:

$ gem install dm-core --pre

2) Install an adapter:

$ gem install dm-sqlite-adapter --pre

3a) Install supporting gems:

$ gem install dm-migrations dm-transactions --pre

3b) OR install a metagem with several well tested supporting gems:

$ gem install data_mapper --pre

This pulls a nice base stack for DM development. The gems included are:

Or use this one-liner to install everything in one go:

$ gem install data_mapper dm-sqlite-adapter --pre

What's changed?

To see more information about the tickets we've closed since 0.10.2 check out the current milestone status on Lighthouse.

How to report issues

Please report any issues you find in IRC, on the mailing list, or in the tracker: